• Wobei die Arduino Fernsteuerung und der Empfänger ja auch für andere Sachen nutzbar wären. Können wir am besten in Dortmund mal drüber fachsimpeln!

    Ja klar, würde Deiner Fernsteuerung auch gerne mal unter's Röckchen schauen.

    Im Hinterkopf hatte ich gemeint, dass Du Deine Komponenten als Bauanleitung für unseren Nachwuchs bereitstellen kannst. Die Meisten drucken lieber in 3D als auf Lochraster zu löten. => Darum die Platine.

  • IBF Kann ich die Schraubklemmen an der Ladestation als Spannungseingang nutzen? Ich habe gemessen, dass die Masse Klemmen mit jeweils einer Masse Klemme vom Rundstecker parallel sind. Bei den Pluspolen kriege ich jedoch keine Durchgangsmessung. :/

  • IBF Kann ich die Schraubklemmen an der Ladestation als Spannungseingang nutzen? Ich habe gemessen, dass die Masse Klemmen mit jeweils einer Masse Klemme vom Rundstecker parallel sind. Bei den Pluspolen kriege ich jedoch keine Durchgangsmessung. :/

    Nein, nicht direkt aus einem Netzteil.

    Erläuterung für den technisch visierten Roboteer:

    - X4 und X5 sind die Eingangs-Stecker (Lochstecker bzw. -buchsen), an denen die Netzteile angeschlossen werden

    - Über eine Diode (=Schutz gegen falsches Anschließen / Verpolungsschutz) zu den IC3 und IC8, das sind die Spannungskonstanter, die aus der Eingangsspannung die 5,0V machen.

    - Diese stabilisierten Spannungen haben im Schaltplan die Bezeichnung "VCC" und "+5V".

    - Diese stabilisierten Eingangsspannungen gelangen dann an die zwei Schraubklemmen (CON1 und CON2), damit sie weitere Lademodule (ohne eigene Netzteile und Stabilisierungen) versorgen können.

    Wenn Deine zwei Netzteile exakt 5V bringen, dann kannst Du das Lademodul modizifieren, so dass die Schraubklemmen dann als Eingang dienen:

    => Die zwei dreibeinigen Spannungskonstanter auslöten, dann bekommen sie nicht auf ihren Ausgang die Spannung von Deinen Netzteilen.

    Andere Alternative:

    - Auf der Leiterplatte: Die Plus-Zuführungen zu den zwei Schraubklemmen unterbrechen. (Dremel + Zahnarztbohrer)

    - Eine Drahtbrücke von den Plus-Eingängen der Lochsteckern rüberlegen zu den ehemaligen Plus-Ausgängen der Schraubklemmen.

    - Die Schraubklemmen sind dann parallel zu den Lochsteckern.

    - Netzteile können dann mit jeweils >=7.5V an den Schraubklemmen angeschlossen werden. (Polung beachten, sonst geht's nicht ;) )
    - Die Spannnung gelangt dann über die Schraubklemmen und die Drahtbrücke auf die regulären Lochstecker/-buchsen. Von dort dann auf die Spannungskonstanter.

    • Official Post

    Ok, danke! Bin noch nicht sicher welche Lösung ich für am besten halte.

    Hab' mal im Layout nachgesehen.

    Bei der Adaption der zwei Schraubklemmen auf die Stiftbuchsen gibt es ein kleines Problem:

    Die +V2 ist über die obere Leiterbahn (in rot) zugeführt. Du müsstest diese Schraubklemme also auslöten, um zum Unterbrechen der Leiterbahn hinzukommen.

    (Die +V1 ist unproblematisch, lässt sich auf der Unterseite (in blau dargestellt) unterbrechen.)

  • Moin,

    ich habe mich über Ostern auch mal an einen alten Arduino gesetzt und versucht dort eine Steuerung für 2 DC motoren zu programmieren.

    Da ich einen Uno R3 und ein passendes Motor Shield nutze ist Antweight nicht machbar, die beiden platinen alleine sind schon viel zu schwer.

    Aber ging mir auch eher um die machbarkeit, wenn man möchte könnte man ja immernoch erheblich kleiner werden mit nem Nano oder so.

    Was mir aber aufgefallen ist: die verzögerung bei den signalen ist relativ lange. Also von Input bis reaktion des Bots vergeht merklich Zeit.

    Durch den Aufbau des Motor shield kann ich leider nicht mit interrupts arbeiten (der uno hat nur 2 pins die mit interrupts arbeiten, davon ist aber einer die klemme für einen der Motoren). ich arbeite jetzt mit polling.

    Wenn das sehr langsam reagiert, liegt das an dem polling oder ist mein code einfach nur so schlecht und langsam - oder sind die 16Mhz des arduino einfach generell kritisch für einen selbstbau-esc?

    Wie ist da deine erfahrung?

    Edited once, last by EmoJack (April 11, 2023 at 9:49 AM).

  • Wenn das sehr langsam reagiert, liegt das an dem polling oder ist mein code einfach nur so schlecht und langsam - oder sind die 16Mhz des arduino einfach generell kritisch für einen selbstbau-esc?

    Mit den Arudions kenne ich mich aktuell noch nicht aus. Ich nehme ganz normale Microcontroller für die Fahrtregler her.

    Deshalb meinen Kommentar als o.o.t. betrachten.:

    {

    Taktfrequenz ist bei mir auch auf 16Mhz eingestellt. Das reicht normalerweise aus, um bis zu 8 Kanäle im Polling abzufragen. (Interrupts vermeide ich seit den ersten Erfahrungen mit den 40Mhz-Funken. Da kamen so viele Störsignal rein, dass.....)

    Beim Pollen der Signale ist es empfehlenswert, eine Zykluszeit für den Aufruf der RX-Abfrage bis maximal 20µs Verzögerung zu schaffen. Ansonsten hast Du bei den Empfängersignalen einen zu großen Jitter drauf. => Zittern der Motoren.

    }

  • Ok, Danke für die Rückmeldungen.

    Ich hab mir das grad nochmal angesehen: das polling scheint auch bei mir nicht das problem zu sein. und mehr als 3 Kanäle habe ich erstmal nicht vor zu nutzen. da sollte also noch Luft sein.

    Wenn ich nur die daten vom empfänger einlese und über den seriellen monitor ausgebe ist die verzögerung so gering, dass man es nicht mehr wahrnimmt mit bloßem auge.

    Das Problem entsteht also beim verarbeiten der werte.

    Ich arbeite aktuell mit mehreren if/else schleifen, da die drehrichtung der Motoren über ein digitalen Wert umgesetzt wird. für jeden motor muss also je nach drehrichtung erst ein pin auf HIGH oder LOW gesetzt werden, bevor Strom auf den Motor kommt. Ich vermute, hier liegt der Hund begraben.

    Das Thema zittern der Motoren ist aktuell kein problem. Da hab ich bei neutral ne kleine totzone eingestellt und sobald der motor dreht sind die kleinen änderungen nicht mehr relevant. Ist natürlich nicht ideal, aber bei nem kleinen, langsamen antweight denke ich kann man damit leben.

    Da werd ich dann die nächsten Tage nochmal etwas das internet durchforsten, wie andere das lösen. ich bin sicher, da gibt es einen schöneren weg.

  • Ich hab mir das grad nochmal angesehen: das polling scheint auch bei mir nicht das problem zu sein. und mehr als 3 Kanäle habe ich erstmal nicht vor zu nutzen. da sollte also noch Luft sein.

    Wenn ich nur die daten vom empfänger einlese und über den seriellen monitor ausgebe ist die verzögerung so gering, dass man es nicht mehr wahrnimmt mit bloßem auge.

    Wir können die Sache gerne weiter erörtern und diskutieren. => Ich glaube, Du hast den Punkt mit dem Jittern von mir etwas falsch verstanden. ;)

    Wir versauen aber mit unserer Diskussion den Baubericht von FIO's Ant-Fahrtregler auf Arduino-Basis.
    Eröffne doch bei den technischen Kapiteln (z.B. Elektronik/Fahrtregler) einen eigenen neuen Thread, wo Du dann separat Dein Projekt vorstellst. Dann ist das unabhängig von diesem Thread hier. ;)

  • 20240218_002556


    20240218_163104

    Meeeeehr!


    Edit: Noch ein paar Worte dazu. Die Spannungsanzeigen, die ich nachgekauft habe, sind etwas kleiner als die vorherigen. Das war mir beim Kauf gar nicht bewusst, aber kleiner ist für einen Antweight grundsätzlich erstmal besser.

    Auf Thingiverse habe ich nun Chassis V4_2 hochgeladen, dass an das kleinere Voltmeter angepasst ist und ein paar kleine andere Verbesserungen enthält.

    Zudem habe ich die Spannungsanzeigen in verschiedenen Farben gekauft, um zusätzlich die Bots besser auseinander halten zu können.

  • Serienproduktion? :thumbup::saint:
    Finde ich gut, dann brauche ich die Ant-Rockeys auf kupferkaschierter Platinenbasis vorab nicht durch die BRD schicken.

    Solche kleinen Spannungsanzeigen habe ich auch schon gekauft, aber natürlich noch nicht zum Einbauen gekommen.
    Danke für den Hinweis, dass es da unterschiedliche Größen gibt. Muss ich bei der nächsten Bestellung aufpassen. (Bin bei den Gehäusen nicht so flexibel wie mit 3D-Druck)

    • Official Post

    Die Bots waren jetzt schon einige Events lang ohne große Ausfälle im Einsatz.

    Auf der Intermod im April war ein Akku kaputt gegangen, aber nur weil ich ihn beim Laden falsch herum angeschlossen hatte. Dabei habe ich direkt auch eine von Reiners Ladeplatinen mit gegrillt. Auf der Messe konnte ich aber einen neuen Akku kaufen und den Schaden schnell reparieren.

    Auf der Messe hatte mir Ralf das elevon mixing für die flysky fs-i6 gezeigt. Damit habe ich nach der Messe alle Funken so eingestellt, dass sich alle 4 Bots gleich steuern lassen.

    Auch war aufgefallen, dass die Bots mich gehobener Schaufel ziemlich bescheiden fahren. Das habe ich behoben, indem ich an der vorderen Gehäusekante die mittlere Schraube durch eine größere ersetzt habe. Nun bietet der große Schraubenkopf in der Mitte einen definierten Auflagepunkt für das Gehäuse auf dem Boden. Kleine Änderung mit großem Effekt.


    In Luxemburg gab es dann nach und nach die ersten Ausfälle bis am letzten Tag nur noch einer von vier Bots einsatzbereit war.

    Eine Schwachstelle im Design ist die Schaufel. Ist die Schaufel gehoben entsteht zwischen dieser und dem Gehäuse eine Lücke. Ein zweiter Bot kann seine Schaufel genau in diese Lücke stecken und so die Mechanik blockieren. Der Servo hat leider genug Kraft um sich selbst im Block zu zerlegen. Erstaunlicherweise geht dabei nicht das Getriebe kaputt. Stattdessen entsteht ein Riss im Servo Gehäuse, sodass sich eine der Getriebewellen aus ihrer Lagerung drücken kann.

    Bei einem Bot scheint leider auch die Servo Elektronik was abgekriegt zu haben. Solange der Servo angeschlossen ist, spinnen auch die Antriebsmotoren. Ist der Servo abgesteckt, funktioniert der Rest normal. Muss ich noch genauer analysieren.

    Ansonsten lassen auch die Antriebsmotoren nach einier Zeit nach. Ich habe nicht die an anderer Stelle vorgestellten N20 Lagerblöcke zur Verstärkung der Abtriebswelle verwendet. Das hat sich gerächt. Zudem fies: In den Gruben der Arena schauen die Enden der Transportschlaufen heraus. Diese sind schon etwas ausgefranzt. Die losen Fäden sind ein gefundenes Fressen für Getriebe :(.


    Ich habe also ein paar Wartungsarbeiten und evtl. Verbesserungen im Design vor mir...

    • Official Post

    Danke für die Info. Interessant.

    Eine Schwachstelle im Design ist die Schaufel. Ist die Schaufel gehoben entsteht zwischen dieser und dem Gehäuse eine Lücke. Ein zweiter Bot kann seine Schaufel genau in diese Lücke stecken und so die Mechanik blockieren. Der Servo hat leider genug Kraft um sich selbst im Block zu zerlegen. Erstaunlicherweise geht dabei nicht das Getriebe kaputt. Stattdessen entsteht ein Riss im Servo Gehäuse, sodass sich eine der Getriebewellen aus ihrer Lagerung drücken kann.

    Sind bei Dir als Waffen-Servo auch die mit den 3A verbaut, die Du mal zu Kaufen gefunden hattest?
    Die hatte ich bei einem Beetle in Dortmund im Einsatz. Allerdings mit 5V und maximal 2A. Die Belastung hatten sie dann ausgehalten. Allerdings zu wenig Kraft, um die gegnerischen 1.5kg umzudrehen.

    Andere Servos mit weniger Kraft (=weniger Stromaufnahme) bei den Besucher-Ants verwenden?

    Bei einem Bot scheint leider auch die Servo Elektronik was abgekriegt zu haben. Solange der Servo angeschlossen ist, spinnen auch die Antriebsmotoren. Ist der Servo abgesteckt, funktioniert der Rest normal. Muss ich noch genauer analysieren.

    Genau aus solchen Gründen sind bei meinen Fahrtreglern maximal 0.5A für Empfänger und Elektronik erlaubt. Damit niemand auf die Idee kommt, da einen Servo anzustecken. :saint:
    Jetzt will ich es nicht besser wissen, aber eventuell bringt das testweise Anstecken von einem Elko an den 5V für den Servo schon mal einen Hinweis. (=> Servo kann nicht die korrekte Position finden, ruckelt und zuckt => ständige gepulste Stromaufnahme, stört die Elektronik für den Fahrantrieb. => ???)

    • Official Post

    ... Zudem fies: In den Gruben der Arena schauen die Enden der Transportschlaufen heraus. Diese sind schon etwas ausgefranzt. Die losen Fäden sind ein gefundenes Fressen für Getriebe :(.

    Da muß mal ein Feuerspucker ran und die Fäden verschweißen:evil:

    Im Großen und Ganzen haben die Bots doch recht lange und viele Einsätze durchgehalten:thumbup:

    • Official Post

    Da muß mal ein Feuerspucker ran und die Fäden verschweißen:evil:

    Hab ich seit Jahren nicht mehr gemacht und würde das auch für etwas zu ungenau halten...

    Aber für sowas reichen ja auch Vapor-Spielereien, da braucht man dann auch nicht so viel Sorge um den Rest der Arena haben :P

    "Spiel mit dem Feuer. Tu es.
    Denn man kann einem Kind hundertmal sagen, die Herdplatte sei heiß. Die Bedeutung wird ihm erst in dem Moment, in dem es trotzdem drauffässt klar.
    So lernt doch jeder für sich selbst, in dem großen Spiel das Leben heißt. Und das Feuer ist einer der anspruchsvollsten, dennoch lohnendsten Mitspieler."

    Ps: Nicht käuflich, aber buchbar