Fahrtegler4_1 (Dreikanal)

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Das nenne ich doch mal eine richtige Innovation die Halbbrücken so zu schalten wie man sie gerade braucht, Super!
      Also bei der Verdrahtung gut drauf achten dass die Pluskabel symetrisch aufgebaut sind.
      Ich brauche da auch kein Dressurpferd, sondern eher zwei Zugpferde die am gleichen Strang ziehen :D
      haben ist besser als brauchen
    • Also bei der Verdrahtung gut drauf achten dass die Pluskabel symetrisch aufgebaut sind.


      Es wird natürlich nichts so heiß gegessen, wie es aussieht. Aber man sollte wissen, dass jeder "Übergang" einen elektrischen Widerstand darstellt. Und die sollten weitgehend gleich sein.

      Beispiel, wie es nicht gemacht werden sollte:


      Die Endstufe von dem linken Kanal hat den Übergangswiderstand von der ersten Klemme auf die Drahtbrücke. An der rechten Klemme dann der Übergangswiderstand von der Drahtbrücke (kommend) und der Übergangswiderstand zum Draht (gehend).
      Es wird funktionieren, aber die rechte Endstufe wird mehr ackern müssen. (Womit wir wieder bei den Pferden wären. :D)

      Sieht als Ersatzschaltbild ungefähr so aus:


      Nur der Vollständigkeit halber: So sollte es gemacht werden:



      (Ich weis, dass ihr mir das auch mit einem Text-Dreizeiler geglaubt hättet, aber für unsere potenziellen Neuzugänge wollte ich das etwas detailierter dargelegen..)
      .
      Interesse an Elektronik für Schaukampfroboter und Kettenfahrzeuge (Fahrtregler, ESC) ? => http://www.Robots.IB-Fink.de
    • Original von bat_boy
      Ich würde das so nicht machen. viel einfacher und leichter wäre eine dicke Kupferdrahtbrücke, an die in der Mitte das eigentliche Kabel angelötet wird. Somit wäre alles wirklich symetrisch.


      (Separater Punkt: ich ärgere mich immer, wenn auf den Baugruppen herumgebruzzelt wurde und ich dann bei kostenlosen Updates oder Reparaturen erst mal wieder alles zurücklöten und bereinigen muss.... aber das ist ein anderes Dauerthema....)

      Dann:
      Es geht die Flexibilität verloren. (Den kleinen Bügelschalter am Fahrtregler eingeschaltet => Defaultbetrieb => H-Brücke statt Dual-Current => Kurzschluss wegen von iben nicht sichtbarer Lötbrücke. => U.u. Defekt der Baugruppe)


      Mit einer harten Lötverbindung versucht eine MOSFET-Halbbrücke (mit Fertigungstoleranzen) die andere MOSFET-Halbbrücke (auch mit Fertigungstoleranzen) hart zu übersteuern. Während der Motor mit seiner Zuleitung eine kleine "ausgleichende" Dämpfung hat.
      (Beachtet die Aufteilung der Ströme beim Testaufbau: Von den 8Ampere musste eine Endstufe 5A übernehmen, die andere nur 3A)
      Somit genau umgekehrt, wie es beim Parallelschalten von Endstufen sein muss!

      @BB-Dirk: Schau einmal auf die Baugruppe von dem 30Ampere-Lader für die Hawker-Akkus. Da sind goldene Lastwiderstände auf dem Kühlkörper. Neben den Shunts zur Strommessung dienen die kleineren Widerstände einzig und alleine dem Zweck, dass man die Emitterausgänge von den Endstufen-Transistoren künstlich mit einem Widerstand versieht, damit man sie 'ein bisschen synchronisiert' parallelsxhalten kann. (Siehe auch mikrocontroller.net/topic/61601)

      MOSFETs reagieren zwar anders wie bipolare Transistoren, aber es handelt sich bei den BTN7960B nicht um reinrassige MOSFETs, sondern da ist noch jede Menge Zeugs integriert, um die ganzen Funktionalitäten zu ermöglichen. Und dass die Schutzschaltung nicht immer funktioniert, hat meine erste Inbetriebnahme vor ein paar Tagen gezeigt. (MOSFET-Halbbrücke abgefackelt)


      Von einer Lötverbindung direkt bei den Endstufen ist abzuraten.
      .
      Interesse an Elektronik für Schaukampfroboter und Kettenfahrzeuge (Fahrtregler, ESC) ? => http://www.Robots.IB-Fink.de
    • Original von Flatliner
      Gut dass drüber gesprochen wurde, ich hätte es sonst vielleicht so gemacht wie BB_Dirk es vorgeschlagen hat.
      (ist nur eine Lötstelle statt zwei, Faulheit siegt:D )


      Ich behaupte nicht, dass der Stärkere der beiden MOSFET-Halbbrücken zwangsweise krepieren muss. (Oder der Schwächere der Beiden, weil er vom Stärkeren auf seiner Ausgangsseite mit Strom gefüttert wird, statt was abgeben zu können.... *grübel*)

      Aber warum soll man es provozieren? (Man fährt im Auto im Stadtverkehr mit 50/60km/h auch nicht ständig im ersten Gang, obwohl es die Autos mittlerweile schaffen würden. ;)

      Es wäre mir wirklich recht, wenn bei den ersten Test-Inbetriebnahmen die Sache noch nicht bis zum Letzten ausgereizt würde. Vor allem, s.o., würde alleine schon das Schließen des kleinen Parametrierungsschalter zu einem satten Kurzschluss führen.
      .
      Interesse an Elektronik für Schaukampfroboter und Kettenfahrzeuge (Fahrtregler, ESC) ? => http://www.Robots.IB-Fink.de
    • Wie gesagt, die Kupferbrücke würde über den Plusklemmen der beiden Kanäle eingesteckt und an diese Kuperbrücke das eigentliche Kabel. Aber ich hatte am Freitag mit dem Heiko gesprochen, er sagt, wieder Reiner, dass man das so nicht machen sollte. Die beiden parallelen Kabel wäre die bessere Lösung aufgrund des benötigten Widerstandes. Bedeutet für mich aber auch,, dass eine gewisse Kabellänge benötigt wird.
      ....ein Event muss her
    • Bedeutet für mich aber auch,, dass eine gewisse Kabellänge benötigt wird.

      Ja, so war der Hinweis in gewissem Sinn auch gedacht. Die beiden Zuleitungen helfen, dass bei den Endstufen zueinander nicht soviel Strom fließt und eine gewisse "Synchronisierung" stattfinden kann.
      (Kann man in gewissem Sinn so betrachten wie den Vorwiderstand von einer LED.)

      Natürlich wäre eine simple Lötbrücke an der Unterseite einfacher zu realisieren, da gebe ich Dir recht. Bei anderen Baugruppen hätte ich da auch keine Bedenken. Aber bie 70 Ampere sollte man ein bißchen vorsichtig sein.
      (Ähnlich wie die Fliegenpatsche mit einem Loch in der Mitte der Schlagfläche. Slogan: "Wir geben jedem eine Chance".)
      .
      Interesse an Elektronik für Schaukampfroboter und Kettenfahrzeuge (Fahrtregler, ESC) ? => http://www.Robots.IB-Fink.de
    • Ähnlich wie die Fliegenpatsche mit einem Loch in der Mitte der Schlagfläche.

      Wieso Fliegen? Was ist mit den Pferden passiert? Oder reden wir hier von Pferdefliegen?

      LOL
      Marien

      Scraptosaur, Midnight Oil, Lt Lee, Mecha Knights, Rockey, Race Robots, Artbots, Linefollowers.

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Marien ()

    • Reiner: wie gesagt, keine Lötbrücke, damit wäre der Regler ja nur schwierig universell einsetzbar. Die Brücke tatsächlich über die Schraubklemmen deiner angelöteten Klemmen, aber ist jetzt nur noch akademisch. Machen sollte man das nun nicht. Aber wie lang sollten die Kabel den sein? 20cm? oder länger?
      ....ein Event muss her
    • keine Lötbrücke, damit wäre der Regler ja nur schwierig universell einsetzbar. Die Brücke tatsächlich über die Schraubklemmen

      Ah... ok... hatte ich dann falsch verstanden. Ich dachte, es war eine direkte Lötverbindung an der Unterseite zwischen den beiden fetten Lötpads gemeint. Sorry, Mißverständnis.

      Aber wie lang sollten die Kabel den sein? 20cm? oder länger?


      Die meisten punktuellen Spannungsverluste entstehen an den Klemmen bzw. Klemmstellen (darum brennen z.B. bei einem Haus mit Ursache "Elektrik" meistens die Klemmstelle im Verteiler oder in einer Verteilerdose. Ganz selten - habe ich noch nie gehört - dass eine Leitung selber für den Wohnungsbrand sorgt.).
      In den Normprüfungen für elektrische Geräte spielen daher die Klemmen eine ganz wichtige Rolle. Es ist z.B. erlaubt, einen 1m langen Kupferdraht an jede Klemmstelle anzubringen. Die Verlustleistung der Klemme (Hitze) wird in den Draht überführt. Damit schafft man die Normprüfungen leichter.

      Überführt auf unser Problem bzw. Deine Anfrage: Im Prinzip ist es relativ egal, ob der Draht jetzt 20cm oder 40cm lang ist. Die Kontaktstellen sorgen für den Übergangswiderstand.
      Nach meiner Ansicht ist es nur wichtig, dass die Drähte ungefähr die gleiche Impedanz abbilden, also einigermaßen "symmetrisch" sind.

      Ganz symmetrisch wird man den Stromfluss bei dieser Fahrtregler-Anwendung ohnehin nicht hinkriegen. Dafür sind die internen Toleranzen der MOSFET-Halbbrücken zu hoch. (Siehe Aufteilung der 8A in 5A und 3A).

      Rein gefühlsmäßig hätte ich eine Leitungslänge von 30cm mit 2.5qm als angemessen empfunden. 4qmm geht natürlich auch, muss aber nicht sein. Die gemeinsame Verbindung vom Motor zum Minus-Anschluss sollte in 4qmm sein. (Die Drähte für die Klemme bitte mit Aderendhülsen crimpen. :D . Am Besten nicht mit einer PZ3, sondern PZ4 => man achte auf die Form des Stempels und der Matrize: sigma.octopart.com/23748292/image/Weidmuller-PZ-4.jpg => ergibt keine "Rauigkeit" der Crimpung im Vergleich zur früheren PZ3)

      Ach ja,... noch wichtig: Auf dem Fahrtregler befinden sich für jeden Power-Ausgang auch 4 Supressordioden. Die sind dafür ausgelegt, irgendwelche "Überschwinger" der vom Motor zurückgelieferten Spannung zu vernichten. Allerdings nicht besonders für hohe Ströme ausgelegt, wenn sie länger fließen.
      Im Normalbetrieb des Powerausgangs , also der H-Brücke, wird der Motor durch eine Stotterbremse zum Halten gebracht. Heißt: Wenn der Motor frei läuft, entsteht bei ihm eine Spannung ("Generatorbetrieb") die dann über die Baugruppe "vernichtet" werden muss.

      Die Stotterbremse wirkt auch in dieser Anwendung mit parallelgeschalteten Ausgängen noch. Aber ich würde hier gerne noch etwas "Sicherheit" in die Anwendung einbauen. :D Warum einen Defekt der MOSFET-Halbbrücken riskieren, wenn es noch eine Möglichkeit gibt? Wie bei einem Relais würde ich auch hier gerne noch eine sogenannte Freilaufdiode parallel am Motor haben. Hab' für den Testlauf bei Flatliner-Dirk schon eine herausgesucht. Ich denke, ein Dauerstrom von 60Ampere und ein Spitzenstrom von 120A, das müsste ausreichen. :D

      Warum diese Diode? In dem für euch entwickeltem Baugruppen-Park gibt es auch den "Powerswitch". Da sind vier MOSFETs parallelgeschaltet, die jeweils laut Datenblatt bis zu 120A können sollten. *lach* . Am Ausgang von der Baugruppe habe ich auch eine Freilaufdiode integriert, die kann 20A Dauerstrom.
      Bei den Tests habe ich festgestellt, dass die MOSFETs kalt wie eine Hundeschnauze bleiben. Da rührt sich nichts. Aber die Freilaufdiode macht sich mit erhöhter Körpertemperatur bemerkbar.
      Heißt: Beschleunigen ist kein Problem, aber beim Abschalten der "Leerlauf" von dem Spinnermotor.
      In dieser Richtung muss ich zugegebenerweise noch etwas Forschungsarbeit stecken. Geht aber erst nach MMM....


      @BB-Dirk: Du hast noch Kontakt zu Heiko? Das ist schön. Irgendwie hört und liest man von ihm im Forum nichts mehr. :(
      .
      Interesse an Elektronik für Schaukampfroboter und Kettenfahrzeuge (Fahrtregler, ESC) ? => http://www.Robots.IB-Fink.de
    • Gestern Morgen, wieder 6 Uhr 30 auf dem Stalker-Testgelände:

      Zeit für einen Outdoor Test von Alptraum. Reiners 4_1 Regler mit der neuen Dual-Current Funktion muss sich heute beweisen.
      Als erstes die Fahrfunktionen: Die Antriebe laufen einwandfrei. Der Bot ist eigentlich viel zu schnell, eine kleine Nebenwirkung der größeren Räder und der höheren Betriebsspannung mit 4LiFe Zellen. Die Geradeausfahrt (ohne Gyro) ist wie üblich nicht besonders gut, da muß noch etwas getrimmt werden. Aber das liegt nicht am Regler.
      Dann das Sägeblatt: Es dreht sehr schön in etwa 2-3 Sekunden auf über 8000 Upm hoch, da hält man gerne etwas Abstand.
      Das Fahren mit voll drehender Scheibe ist ein Vergnügen, artig wird bei Lenkungen ein Beinchen (Rad) angehoben. Nach einem etwas übermütigen Lenkmanöver mit plötzlichem Richtungswechsel hat Alptraum sich zur Entspannung auf den Rücken gelegt und das Sägeblatt im Asphalt vergraben :D
      Das parallele Ansteuern der MOSFETs war also erfolgreich!
      haben ist besser als brauchen
    • Vielen Dank für den Praxistest unter realistischen Bedingungen.

      Freut mich, wenn der Fahrtregler jetzt soviel Strom liefert, dass der Spinnermotor anläuft und "hochzieht".
      Nachdem auch der Asphalt als Sparringspartner funktioniert hat (keine Überstromabschaltung des Spinnermotors unter Last) denke ich, dass der Dual-Current-Mode nicht dafür sorgt, dass sich die zwei MOSFETs gegenseitig den Strom überlassen. ;)

      Was ich leider vergessen hatte: Ich wollte Dir noch eine fette Freilaufdiode zukommen lassen. (Doppelte Sicherheit im Generatorbetrieb). Habe ich wohl beim letzten Päckchen vergessen.
      .
      Interesse an Elektronik für Schaukampfroboter und Kettenfahrzeuge (Fahrtregler, ESC) ? => http://www.Robots.IB-Fink.de
    • Kurze Rückmeldung wg. dem Defekt bei Replikators Disrupter (FACTs 2016):

      Wie Daniel vorort schon bemerkt hatte, war der Quarz "umgebogen" und drückte auf die Pins vom Microcontroller. Motor 2 und der Waffenkanal funktionierten nicht mehr.

      Mein Befürchtung war, dass der Microcontroller einen Kurzschluss durch das Metallgehäuse des Quarzes bekommen hatte. Aber, nachdem die eingesetzten PIC-Microcontroller ja robuste Arbeitstiere sind, ist denen durch den Kurzschluss nichts passiert. :D

      Ursache gefunden:


      Faszinierend war die Fehlersuche: Ich bin mit der Meßspitze des Oszis auf den zweitrechten Pin. Durch den Druck wurde die Verbindung hergestellt, der Motor 2 ratterte los. Spitze weg => Motor bleibt stehen. 8o

      Soweit also mal der kurze Fehlerbericht.

      Ich liefere meine Fahrtregler immer ohne Gehäuse aus. Erstens ist das ziemlich aufwändig für mich zu bauen. Zweitens kommen die Fahrtregler ja nicht in die Hände von Laien oder Kindern, sondern Modellbauern. Die sind normalerweise selbst pfiffig genug, sich irgendeine Schutzhülle zu basteln. Sollte man halt nur aufpassen, dass beim Ein-/Ausbau nicht irgendwas "verbogen" wird. ;)

      @Replikator: Päckchen geht morgen weg. Material/Ersatzteile habe ich nichts gebraucht. Arbeitszeit und Porto ist unter Vereinskollegen kostenlos. ;)
      .
      Interesse an Elektronik für Schaukampfroboter und Kettenfahrzeuge (Fahrtregler, ESC) ? => http://www.Robots.IB-Fink.de
    • Wow... *sprachlos*. 8o
      Ich hasse Elektronik... Die Fehler zu finden, das ist manchmal so ein K(r)ampf... ;( Hatte ich die letzten zwei Wochen selber auf der Arbeit... Eine Baugruppe zeigt u.a. die Puls-Frequenz unserer Anlagen an... Nun zeigt besagte Baugruppe immer stumpf das doppelte der Eingangs-Frequenz an. Geht man nun mit dem Oszi-Tastkopf auf die kritischen Stellen, stimmt die Anzeige plötzlich wieder... Ok, im Tastkopf ist ja u.U. noch etwas Elektronik, die Einfluss haben kann. Aus jucks haben wir dann nur mal einen Schraubenzieher dran gehalten, worauf hin wieder die korrekte Frequenz angezeigt wird... Oh mann...


      Aber b.t.t.:

      Vielen Dank Reiner!
      Da mein Disruppi gerade eh in Einzelteilen vorliegt, baue ich deinen Ersatzregler dann aus und verschicke ihn, zusammen mit deinem Beetle-Regler, in den nächsten Tagen zu dir! :D
      Gibt es schon eine Prognose, woher der Defekt führen könnte?
    • Replikator schrieb:

      Gibt es schon eine Prognose, woher der Defekt führen könnte?
      Daniel und ich hatten bei der Erstinspektion vermutet, dass beim Ein-/Ausbau oder anderen internen Bot-Umbauten der Quarz "abgeknickt" wurde und dann mit Gewalt gegen den Prozessor drückte. Die Kraft hat dann an diesen zwei Pins zu einer kleinen "Verschiebung" des Chips geführt. => Der Klügere gibt nach, das war die Lötstelle und die Leiterbahn. :D

      Bin ja froh, dass ich den Prozessor nicht wechseln muss. Ist wie bei einer Autoreparatur: Um an die Lichtmaschine zu kommen müssen zuerst zwei andere Aggregate ausgebaut werden. Damit die ausgebaut werden können, muss zuerst was Anderes raus. Damit das "Andere" raus kann, muss zuerst....
      Beim Fahrtregler müsste zum Prozessorwechsel zwei der fetten Elkos raus. Geht, aber mir tut das viele Lötzinn auf der dicken Power-Leiterbahn an der Unterseite leid. :saint:
      .
      Interesse an Elektronik für Schaukampfroboter und Kettenfahrzeuge (Fahrtregler, ESC) ? => http://www.Robots.IB-Fink.de
    • Ok, aber das mit dem Quarz bezweifle ich aber schon. Ok, in meinen Bots ist es immer argh eng, aber der Regler hat, wenn er irgendwann drin ist, viel Platz-> Da die Karosse ja schräg ist, heißt es: Umso weiter im Bot, also Richtung Boden, desto mehr Platz gibt es! :D Der Platz zur Frontpanzerung, da unten, ist bestimmt zwischen 3-5cm. (die Quarzseite guckt nach Vorne)
      Und auf den leicht "in der Luft" stehenden Quarz habe ich immer aufgepasst. Also wenn, dann ist er durch Beschleunigungskräfte ein wenig gekippt. Aber mit soviel kraft auf den Prozessor drücken? ?(
      Hätte jetzt eher auf Vibrations-Bruch oder auf ein ungewolltes verbiegen der Leiterplatte getippt... X/
    • Bitte nicht falsch verstehen! Das ist keine Kritik an dem Handling von der Baugruppe. Ich weis ja selber, wie schnell mal irgendwo was beim Einpassen "anschlägt". Keine Ahnung, warum der Quarz in die stabile Seitenlage gekippt ist. Egal. Ich hab' das Foto und die Erläuterungen ja aus anderen informellen Gründen eingestellt. ;)
      .
      Interesse an Elektronik für Schaukampfroboter und Kettenfahrzeuge (Fahrtregler, ESC) ? => http://www.Robots.IB-Fink.de